Our first unstable release

So as a part of starting soft fork maintenance we need to start making releases and I am happy to say today we made our first unstable release :partying_face:

Please do open issues if something is broken. But please do first check with upstream nixpkgs that the issue has not already been reported there.

For more reading about our plans on maintenance do read:


Awesome work @isabel!


Updated! Thank you for all of the work c:


Amazing work!! :smile: (padding text :p)

1 Like

Awesome! Couple questions, though:

  1. What is the recommended way to switch an existing NixOS system that is tracking nixpkgs-unstable to use Aux?
  2. What makes this a soft fork? Does that just mean trying to stay close to upstream for the time being?
1 Like
  1. You can change the organization name in your flake input or channel from “nixos” to “auxolotl”.
  2. Yes, soft fork means we are maintaining compatibility and continuing to pull in changes from upstream. Functionally the fork should be the same as upstream during this phase.

Awesome! If anyone else uses outdated revision for whatever reason, yes, it works as drop-in replacement!


Switching from NixOS/nixpkgs/nixpkgs-unstable to auxolotl/nixpkgs/nixpkgs-unstable right now.

Recognized some packages were compiled from source (fwupd, tpm2-tools, SDL2_mixer) which was surprising :thinking:

And successfully booted :tada:
Da\m\n I rly love this technology, when was the last time you were able to switch the publisher of your linux distro (trying to be technically correct for the time being :wink: ) by changing 1 word? :exploding_head:

I love it!!! :heart:


I noticed this too but some different packages, this is likely because we don’t have staging where our packages are built by hydra. So we are a little bit more bleeding edge. This will be a much bigger problem when we get to programs like chromium. So we need to work on a workflow that has a staging step.


Thanks for the clarification, makes total sense… And yeah anything Chromium will be a pain to compile locally…

1 Like

Just tried to build from our unstable release on my server. It seems erlang was trying to be built from source. So I don’t recommend rebuilding if you have a package that depends on erlang.


First massive milestone of many!!! Huuuuge thanks to everyone that helped make this one happen!!


Just switched all my machines to use it, works great! Good job :relieved:


Same switched and everything work :smiley:


Running my thinkpad fully on auxpkgs!!!


switched over yesterday–works excellently! i did notice that wpaperd 1.0.1 compiled from source, but now that nix has updated that package too it shouldn’t be an issue (and luckily for me wpaperd is a relatively small program lol)

1 Like

Hopefully, nothing will need compilation from source for todays release.


How do you switch to aux if the system isn’t using flakes yet? Should I just bite the bullet and switch it flakes?

1 Like

I believe you can change your channel to point to the auxolotl/nixpkgs repository, but I haven’t used channels in a while so I don’t have an example on hand.


My naive attempt didn’t work out

I tried:

sudo nix-channel --add https://github.com/auxolotl/nixpkgs.git
sudo nix-channel --update

The update yields:

error: unable to download 'https://github.com/auxolotl/nixpkgs/nixexprs.tar.bz2': HTTP error 404

Looking at the default channel at https://nixos.org/channels/nixos-23.11 there is a listing for a nixexprs.tar.xz, which appears to be an archive of the nixpkgs repo.

So it seems nix-channel is expecting the URL provided to --add to be a nixpgs archive in some form but named nixexprs.tar.* which is not present in the aux nixpgs repo.

I did a quick experiment by forking aux’s nixpkgs repo, made a branch called nixexprs, and ran sudo nix-channel --add https://github.com/ky-bean/nixpkgs/archive/nixexprs.tar.gz aux and sudo nix-channel --update aux did successfully build a derivation. Very very jank solution but it appears to work!